<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working With Junctors</td>
<td>43</td>
</tr>
<tr>
<td>Creating Junctors</td>
<td>43</td>
</tr>
<tr>
<td>Entities, Junctors, and Edges</td>
<td>44</td>
</tr>
<tr>
<td>Working With Groups</td>
<td>44</td>
</tr>
<tr>
<td>Creating Groups</td>
<td>44</td>
</tr>
<tr>
<td>Setting the Group Title</td>
<td>45</td>
</tr>
<tr>
<td>Arranging Grouped Elements</td>
<td>45</td>
</tr>
<tr>
<td>Collapsing and Expanding Groups</td>
<td>45</td>
</tr>
<tr>
<td>Group Colors</td>
<td>46</td>
</tr>
<tr>
<td>Assigning Symbols to Groups</td>
<td>46</td>
</tr>
<tr>
<td>Hoisting</td>
<td>47</td>
</tr>
<tr>
<td>Deleting Selections</td>
<td>49</td>
</tr>
<tr>
<td>Copy and Paste</td>
<td>50</td>
</tr>
<tr>
<td>Layout</td>
<td>50</td>
</tr>
<tr>
<td>Orientation</td>
<td>51</td>
</tr>
<tr>
<td>Bias</td>
<td>53</td>
</tr>
<tr>
<td>Incremental Layout</td>
<td>53</td>
</tr>
<tr>
<td>Managing Large Documents</td>
<td>55</td>
</tr>
<tr>
<td>Managing Memory</td>
<td>55</td>
</tr>
<tr>
<td>Managing Graphic Complexity</td>
<td>55</td>
</tr>
<tr>
<td>Graph Logic</td>
<td>57</td>
</tr>
<tr>
<td>Confidence Spinners</td>
<td>57</td>
</tr>
<tr>
<td>Setting Confidence Values</td>
<td>57</td>
</tr>
<tr>
<td>The Meaning of “Confidence”</td>
<td>58</td>
</tr>
<tr>
<td>Probability vs. Fuzziness</td>
<td>59</td>
</tr>
<tr>
<td>Operators</td>
<td>59</td>
</tr>
<tr>
<td>Numeric Data Types</td>
<td>60</td>
</tr>
<tr>
<td>Basic Operators</td>
<td>62</td>
</tr>
<tr>
<td>Advanced Operators</td>
<td>62</td>
</tr>
<tr>
<td>Junctor Operators</td>
<td>63</td>
</tr>
<tr>
<td>Entity Operators</td>
<td>64</td>
</tr>
<tr>
<td>Setting up for Probabilistic Analysis</td>
<td>64</td>
</tr>
<tr>
<td>Edge Weights</td>
<td>64</td>
</tr>
<tr>
<td>Setting Edge Weight Values</td>
<td>66</td>
</tr>
<tr>
<td>The Edge-Weighting Function</td>
<td>66</td>
</tr>
<tr>
<td>Logical Negation</td>
<td>67</td>
</tr>
<tr>
<td>Domains</td>
<td>69</td>
</tr>
<tr>
<td>Classes and Domains</td>
<td>69</td>
</tr>
<tr>
<td>Working with Classes</td>
<td>69</td>
</tr>
<tr>
<td>Creating A Custom Domain</td>
<td>70</td>
</tr>
<tr>
<td>Creating A Custom Class</td>
<td>70</td>
</tr>
<tr>
<td>Changing Existing Domains and Classes</td>
<td>71</td>
</tr>
<tr>
<td>Exporting and Importing Domains</td>
<td>72</td>
</tr>
<tr>
<td>Resolving Conflicts When Importing</td>
<td>73</td>
</tr>
<tr>
<td>Hiding Domains</td>
<td>73</td>
</tr>
</tbody>
</table>
Getting Started

System Requirements

| Windows          | • Windows 10, Windows 8, Windows 7, or Windows Vista  
|                  | • 200MB free disk space          |
| Mac OS X         | • Intel-based Mac running OS X 10.7.3 or later  
|                  | • 180MB free disk space          |
| Linux            | • Linux 3.0 or later  
|                  | • 200MB free disk space          |

Linux Compatibility

Flying Logic has been tested and found substantially compatible with the following distributions of Linux:

- Debian 8.4.0 (3.16.7, Cinnamon)
- Linux Mint 17.3 (3.19.0, Cinnamon)
- OpenSUSE 42.1 (4.1.12, KDE)
- Ubuntu 14.04 (3.13.0, Unity)

The information in parentheses are the kernel version and default window manager of the distribution.
Installation

<table>
<thead>
<tr>
<th>Platform</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows</strong></td>
<td>• Run the installer provided.</td>
</tr>
<tr>
<td><strong>Mac OS X</strong></td>
<td>• Drag the application to your Applications Folder.</td>
</tr>
<tr>
<td><strong>Linux</strong></td>
<td>• Run the install script provided.</td>
</tr>
</tbody>
</table>

What’s New?

New features in Flying Logic 3.0 have this icon: 3.0

New features in Flying Logic 3.0.1 have this icon: 3.0.1

Editions

Flying Logic is available in two “editions,” the free “Reader Edition” and “Flying Logic Pro.”

**Reader Edition**

The Reader Edition is distributed at no charge, and is used for opening interactive, read-only review of documents created with Flying Logic Pro. Once opened, documents can be exported in the various image formats (PDF, JPEG, PNG), groups may be uncollapsed and collapsed, and confidence values and edge weights may be manipulated, but no changes can be saved.

**Flying Logic Pro**

All features available with no restrictions.
The Document Window

Flying Logic can have multiple documents open at one time. Each document window is divided into several functional parts.

The Canvas

The Canvas is where you do most of the work of building your diagram. See the “Constructing Graphs” on page 23 for information on working with the Canvas.

If the diagram in the canvas is too big to fit into the window, there are several ways to move your view around:

- Use the scroll bars that become active at the bottom and right sides of the Canvas.
- Click and drag in the blank gray background of the Canvas. This gesture is called “sliding,” and causes the view to continuously
scroll in the direction of the gray gesture arrow. The scrolling speed is proportional to the distance you drag from the place where you initially click.

- Click in the Canvas, then hold down the Control key and press (or press and hold) an arrow key to slide the view.
- Use your mouse scroll wheel to move your view.
- Use the Navigation Inspector to easily change the part of the document you are viewing. See “Navigation Inspector” on page 13 for details.

In addition to moving your view around, you can also zoom your view in or out.

- Use the Zoom Slider at the bottom of the canvas or in the Navigation Inspector to shrink the graph down to 25% of its normal size so more is visible, or enlarge it up to 400% of its normal size for use in presentations.
- Click the magnifier icon on either side of the zoom slider to display a popup menu that lets you select a specific zoom level.
- Use the View ➤ Zoom to Fit and View ➤ Full Size commands.
- Hold down the Alt key and use your mouse scroll wheel to zoom in or out.
- Press < or > to zoom in or out, respectively.
The Toolbar

The toolbar contains a row of icon buttons that are used to perform common tasks. Each button has a tooltip that appears when you move the cursor over it to remind you of its function. From left to right the icons in the toolbar represent Undo, Redo, Cut, Copy, Paste, Delete, Add Entity, Insert Entity, Add Entity as Successor, Add Group, Show/Hide Confidence Values, Show/Hide Edge Weights, Show/Hide All Edge Annotations, Show/Hide Annotation Numbers, Show/Hide Entity IDs, Turn On/Off Incremental Layout, and Turn On/Off Project Management. The Toolbar also contains a live search field and a Find button that provides a search dialog.

Document Tabs

When more than one document is loaded in a window, a Document Tab bar will appear just below the Toolbar. The tab of the current document appears with a bright background color, while other tabs have a dark background color.

To switch documents, click the document’s tab. You can close a document in a tab by clicking the close box button at the right side of the tab. You can reorder the tabs by dragging a tab along the bar.

If there are too many documents loaded in a window to show all the tabs, a pop-up menu will appear at the far right of the bar. You can select a document from this menu to make its tab appear in the bar. This will move the document represented by the former rightmost tab to the pop-up menu.

The Sidebar and Inspectors

The Sidebar contains eight collapsible inspectors. Each inspector gives you control over a specific aspect of your Flying Logic document. Click the vertical buttons or press Command (Mac) or Control (Windows) and the corresponding numeral to show or hide the corresponding inspector.
Document Inspector

The Document Inspector contains three tabs: Info, Header, and Footer. The Info tab lets you specify metadata for your document, while the Header and Footer tabs allow you to specify which metadata should appear at the top and/or bottom of each printed page.

Domain Inspector

The Domain Inspector lists the kinds of entities (“entity classes” or just “classes”) you can put into your diagram. There are five predefined groups (“domains”) of classes: the General domain includes two classes:
Generic and Note, and the other four include several additional classes each. Which entity classes you use will depend on the needs of your project. For information on using the Domain Inspector to construct your diagram, see “Constructing Graphs” on page 23. For information on creating your own custom classes, see “Domains” on page 69.

**Tip:** The Domain Inspector’s height can be adjusted by dragging the splitter bar at its bottom.

**Tip:** The Generic and Note built-in classes have their “Show Name” attribute turned off. Therefore, they will be displayed without the name of their class at the top of the entity rectangle, and will have an all-white (or all-yellow) background. You can create your own custom classes that either show or hide the class name. See “Creating A Custom Class” on page 70.

**Navigation Inspector**

The Navigation Inspector contains a thumbnail view of your entire document and a red rectangle that represents the section of the document currently visible in the Canvas. You can click and drag within the thumbnail to move the view, and use the inspector’s Zoom Slider to make the
view larger or smaller.

**Layout Inspector**

Flying Logic documents all “flow” from their beginning to their end in the direction of the arrows (“edges”) that connect the boxes (“entities”), and the **Orientation** popup in the Layout Inspector lets you determine the direction of this flow. The **Bias** popup lets you determine whether Flying Logic’s automatic layout prefers to push entities towards the beginning or end of the document’s flow. For more information, see “**Layout**” on page 50.

**Operators Inspector**

The Operators Inspector lets you set the operators associated with incoming edges for the entities in your document, and the operator associated with newly-created junctors. For more information, see “**Operators**” on page 59.

**Element Inspector**

The Element inspector contains four tabs, one for each kind of element in Flying Logic documents: Entities, Edges, Junctors, and Groups. The controls in each tab of the inspector let you adjust various attributes of the currently selected elements of that kind.
Entity Tab

The Class Popup is used to quickly assign a new class to the currently selected entity or entities. For more information, see “Changing the Class of an Entity” on page 30.

Each entity can have a symbol assigned to it to make it easier to identify. Symbols are assigned to entities using the Entity tab of the Element Inspector. For more information, see “Assigning Symbols to Entities” on page 35.

Edge Tab

Edges can display their edge weight, their annotation, or both and these attributes can be set for all currently selected edges from the Edge Tab. For more information see “Edge Weights” on page 64 and “Text Inspector” on page 16.
Juctor Tab

The operator associated with the currently selected junctors can be set from the Juctor Tab. For more information, see “Working With Junctors” on page 43 and “Operators” on page 59.

Group Tab

The currently selected groups can be expanded or collapsed, and their color can be set, from the Group Tab. Groups can also have a custom icon. For more information see “Working With Groups” on page 44.

Text Inspector

QuickCapture  
Browse Lock  
Style Buttons  
Splitter
The Text Inspector provides several tools for editing the text in titles and annotations for the currently selected element.

Annotations

The **Title Editor** displays (and can also be used to edit) the title of the currently selected entity or group. See “Constructing Graphs” on page 23 for more information about editing titles.

Every element (entity, edge, junctor, group) in the diagram can have its own annotations, and these are created and edited in the **Annotation Editor**. Annotations can be any length and are intended to be where detailed supporting information and underlying assumptions are recorded. Use the splitter to change the size of the Annotation Editor. To create an annotation or edit an existing one, select the element you wish to annotate, then click in the annotations area. If an element has an annotation, it will appear in the diagram with a small yellow circle on it.

Edge annotations can also be displayed as separate boxes with visible text. To display annotation boxes for every edge in the diagram, select the **View ➤ Edge Annotations** command, or click the Show/Hide All Edge Annotations button in the toolbar. To display edge annotations for only selected edges, select the edges then right-click (Mac, control-click) on any of them and select **Show Selected Edge Annotations** from the contextual menu. When an edge annotation is visible, you can edit it directly by either double-clicking it, or by selecting the edge and pressing the Tab key.
The setting for the View ➤ Edge Annotations command overrides the settings for showing individual edge annotations. When it is turned on, all edge annotations will be visible and the individual settings for edges are ignored.

Creating annotations for edges is particularly important, as the edges “hide” your assumptions about why you believe one entity causes (or contributes to the cause of) another. Surfacing these assumptions is a critical aspect of using the Thinking Processes.

QuickCapture

The QuickCapture button in the Text Inspector allows you to create numerous entities quickly by simply typing their titles and pressing Enter. This is particularly useful when you are brainstorming with a group, and need to get a lot of ideas down quickly.
**Tip:** QuickCapture can be activated any time by pressing the E key, and can be exited by pressing Escape.

**Styled Text, Hyperlinks, and Browse Lock**

Annotations can contain styled text and hyperlinks (clickable URLs). These are both editable and viewable in the Annotations Editor of the Text Inspector.

The Browse Lock button to the right of the Annotation Editor is used to switch between editing mode (unlocked) and browsing mode (locked). In browsing mode, hyperlinks are clickable and open the linked-to page in your web browser. In editing mode, they are directly editable.

Styled text attributes can be changed for the currently selected text by using the commands in the **Format ➦ Font** menu.

The text that represents a hyperlink and the underlying URL can be separately edited by placing the insertion point within a link then using the **Format ➦ Edit Hyperlink** command.

![Browse Lock Off](image1.png) ![Browse Lock On](image2.png)

Styled annotations are also editable and hyperlinks are clickable in visible edge annotations. Clicking or editing a hyperlink in a visible edge annotation behaves according to the state of the Browse Lock button in the Annotation Editor.
The hyperlink text can take several forms:

- A URL reference to a web page:
  

- A reference to another Flying Logic document in the same directory as the current document:

  `My Document.xlogic`

- A reference to an entity by Entity ID in another document:

  `My Document.xlogic#42`

- A reference to an entity by Entity ID in the current document:

  `#42`

**Tip:** Entity IDs are assigned the first time they are made visible in the document. Therefore, in the last two cases above, Entity IDs must have been made visible in the referenced document at least once, in order to link to an entity by Entity ID.

In URL terminology, the text of a URL following the (“#”) mark is called the “fragment”. In addition to Entity ID, Flying Logic now supports a number of additional fragment specifiers.

- A more explicit reference to an Entity ID:

  `#entityid=42`

- The exact, case-sensitive text of an entity’s title:

  `#title=This is the Text of the Title`

- The exact, case-sensitive text of an entity’s annotation:

  `#note=This is the text of the note.`
  `#annotation=This is the text of the note.`

- All entities of the named class:

  `#class=Goal`
• **3.0** The exact, case-sensitive text matching either the name or value of user-defined attributes:

  \#attrname=Price
  \#attrvalue=49.99

• **3.0.1** The exact, case-sensitive text matching the name or abbreviation of a resource:

  \#resource=Alice

• All elements matching the Find string:

  \#find=The text to find

• Options for the Find function. These correspond to the checkboxes in the Find dialog (see X). More than one option can be specified by separating the options with a comma. **3.0** The options `entityid`, `attrname`, and `attrvalue` are new to this release.

  \#options=(and|regex|casesensitive|titles|notes|annotations|entityid|attrname|attrvalue|incollapse|wholewords)

More than one fragment specifier may be used by separating them with ampersands (“&”). For example:

  \#find=water&find=tea&options=titles

Will find every entity with the word “water” OR the word “tea” in its title, while:

  \#find=water&find=tea&options=titles,and

Will find every entity with the word “water” AND the word “tea” in its title.

**User-Defined Attributes Inspector**

The User-Defined Attributes Inspector supports adding custom, user-defined attributes to document elements and on the document itself. Each attribute is a name-value pair, and the values can be defined as being String, Integer, Real (floating-point), or Boolean (true or false).

With nothing selected in the document, the User-Defined Attributes Inspector is used to edit the document attributes:
With any other selection the User-Defined Attributes Inspector is used to add, edit, or remove the attributes from all selected elements simultaneously:

User-defined attributes can simply be used as a more structured form of annotation. However, in conjunction with Flying Logic’s scripting system, they can also be used as data in scripted operations, or help improve the export and import of documents. For more information, see the section on “Scripting” on page 77 and the Flying Logic Scripting Guide.
Constructing Graphs

Flying Logic diagrams are technically known as graphs. A graph is a set of vertices (also called points or nodes) linked by a set of edges (also called lines or arrows.) Graphs can generally be used to represent many things, from street maps to social networks. In Flying Logic, graphs are often used to represent a network of causes and effects called entities and the causal relationships between them. The graph can also include junctors, which help you control the way the causal relationships combine, and groups, which help you organize your documents and manage larger documents.
Working With Entities

Entities represent the causes and effects in your diagram. Each entity has a **title**, which is a short descriptive phrase, and can also include a much longer **annotation**. Entities also have a **class**, which is a word or two that describes *what kind* of entity it is, and that appears in a colored bar at the top of the entity. For a description of the classes built into Flying Logic, see the accompanying document, *Thinking with Flying Logic*.

There are several different ways to create new entities within your document. Once you learn them, developing complex diagrams quickly will feel quite natural.

**Add Entity as Successor**

In the toolbar and **Entity** menu is the **Add Entity as Successor** switch:

- **Add Predecessor** (default)
- **Add Successor**

The behavior of several commands and gestures used to add entities to the diagram depends on how this switch is set, and usually you will set it once depending on what sort of diagram you are building. You can also toggle the switch from the keyboard by pressing Command-Shift-E (Mac) or Ctrl-Shift-E (Windows or Linux).

The commands that use this switch either add a new entity pre-connected to an existing one...
...Or they first insert a junctor along the edge, then connect a new entity to it:

In the descriptions that follow, the icon is read “predecessor or successor,” and appears whenever the setting of the Add Entity as Successor switch is observed.

Creating Entities With Menu Commands

- Select a class from the Domain Inspector, then select the Entity ➞ New Entity command or click the New Entity button in the toolbar. If an open group is also selected in the diagram, the new entity will be added to that group. If an entity or junctor is selected in the diagram, the new entity will be created as a ➞ of
the selected entity or junctor. If an edge is selected in the diagram, a new junctor will be inserted along the edge, and the new entity will be made a [entity_target] of the new junctor.

- Select a class from the Domain Inspector and also select an edge in the diagram, then select the Entity ➞ Insert Entity command or click the Insert Entity button in the toolbar. A new entity will be inserted along the selected edge.

- Right-click (Mac, Windows, Linux) or Control-click (Mac) on the gray diagram background or an open group, and select an entity class from the popup menu. A new, unconnected entity will be added to the clicked group or the top level of the document.

- Right-click (Mac, Windows, Linux) or Control-click (Mac) on an existing entity, edge, or junctor; then select an entity class from New Entity in the popup menu. If an edge was clicked, a junctor will be inserted along the edge, and the new entity will be added as a [entity_target] of the new junctor.

Creating Entities With Drag and Drop

- Drag a class from the Domain Inspector, and drop it either on an open group, or on the gray background of the Canvas. A new, unconnected entity will be added to the target group, or the top level of the document.

- Drag a class from the Domain Inspector, and drop it on an existing entity or junctor. The new entity will be created as a [entity_target] of the target entity or junctor.

- Drag a class from the Domain Inspector, and drop it directly on an existing edge. A new junctor will be inserted along the edge, and the new entity will be made a [entity_target] of the new junctor.

Creating Entities With QuickZones

Flying Logic also has special drop zones called QuickZones that allow you to easily place new entities in precise relationships to existing diagram elements without needing to use the Add Entity as Successor switch. With a little practice, QuickZones will become your favorite way to construct Flying Logic diagrams.

QuickZones are near each edge, but not on the edge, and highlight when you move the cursor over them while dragging a class from the
Domain Inspector.

The position of the QuickZones depends on the setting of the diagram orientation popup in the sidebar. In the examples below, the orientation is set to **Bottom to Top**. In this case, the Predecessor QuickZone is underneath entities or junctors. If the orientation were set to **Left to Right**, as in the diagram above, then the Predecessor QuickZone would be to the left of entities or junctors.

- Drag a class from the Domain Inspector to the Predecessor QuickZone of an existing entity or junctor:
• Drag a class from the Domain Inspector to the Successor QuickZone of an existing entity or junctor:

![Diagram](image1)

• Drag a class from the Domain Inspector to the Junctor-Predecessor QuickZone of an edge:

![Diagram](image2)
• Drag a class from the Domain Inspector to the Junctor-Successor QuickZone of an edge:

![Diagram 1](image1.png)

• Drag a class from the Domain Inspector to the Insert QuickZone of an edge:

![Diagram 2](image2.png)
Changing the Class of an Entity

To change the class of all selected entities, use one of the following options:

- Right-click (Mac, Windows, Linux) or Control-click (Mac) on the entity and select the desired class from the popup menu.
- Select a new class in the Class Popup of the Entity Tab of the Element Inspector. See “Element Inspector” on page 14.
- Option double-click (Mac) or Alt-double-click (Windows) on the desired class in the Domain Inspector. See “Domain Inspector” on page 12.

Editing Entity Titles and Annotations

Double-click the entity to begin editing its title, or with an entity selected, press the Tab key. An editor appears over the entity that lets you type or modify the entity title. When you are done editing, press Enter/Return or click outside the editor to commit your changes. If the Text Inspector is visible, you can press Tab again to commit your changes and begin editing the entity’s annotation. Finally, you can press Escape to discard your changes.

You can directly edit an entity’s annotation by selecting the entity then clicking in the Annotation Editor of the Text Inspector. When you are done editing, commit the change by clicking in the background of the Canvas. To remove an annotation, select and delete all the annotation text.

Annotation Numbers and Entity IDs

Flying Logic uses two different numbering systems that you can make visible in each document.
Annotation Numbers are revealed by clicking the Annotation Numbers icon in the Toolbar or by selecting View ➤ Annotation Numbers. Annotation numbers are primarily used for matching textual annotations (or their small yellow bullets) in the Canvas to the corresponding full text of the annotations exported using the File ➤ Export Annotations as PDF or File ➤ Export Annotations as Text commands. Unlike Entity IDs, annotation numbers are ephemeral and are renumbered every time the document is changed, which keeps the annotation numbers in the same order they appear along the flow of the document. This means that if you export notes from a Flying Logic document, then make changes to your document, you will need to re-export the notes for the exported numbers to match.

Entity IDs are revealed by clicking the Entity IDs icon in the Toolbar or by selecting View ➤ Entity IDs. Unlike Annotation Numbers, Entity IDs are durable and continue to exist throughout the life of the entity, unless the entities in the document are explicitly renumbered by using the Entity ➤ Renumber Entity IDs command.

Element Text Attributes

The View ➤ Element Text Attributes, dialog allows you to refine the way Flying Logic displays text throughout your document. It replaces the previous Entity ➤ Title Font Size and Entity ➤ Title Width command. The dialog contains three tabs for adjusting the attributes of entities, groups, and annotations. Each tab contains an area where you can preview the changes you make.
The two radio buttons in this tab let you choose between modifying the attributes of the entity title (the text in the white part of the entity) and the entity class (the text in the colored band at the top of the entity.)

When Font Size is set to “Auto”, Flying Logic selects a font size for entity titles based on the amount of text in the title:
By selecting a particular Font Size, you tell Flying Logic to use a fixed-size font for all entity titles:

Flying Logic normally chooses a fairly narrow width for containing entity titles, but this can cause long titles to be laid out taller than you might prefer. You can use the **Maximum Width Multiple** slider to ask Flying Logic to choose a width for long entity titles.

Clicking the **Reset to Default** button restores the default attributes for the tab.
Group Text Attributes

This tab lets you choose the attributes that are used to display group titles.
This tab lets you choose the default attributes that are used to display annotation text. As annotation text supports styles, this is the style that will be used in the absence of overriding styles.

**Assigning Symbols to Entities**

To assign a symbol, select one or more entities then select the desired symbol from the Icon Popup in the Entity tab of the Element Inspector. To remove a symbol, select the 🎨 icon in the upper-left corner of the popup.
Assigning Symbols to Classes

Symbols can also be automatically assigned to an entire entity class. For instructions on how to do this, see “Creating A Custom Class” on page 70. Whenever entities of such a class are created, the symbol will automatically apply to them, but can still be overridden on an entity-by-entity basis. To revert to the default symbol for a class, select the icon in the upper-left corner of the popup.

Adding Custom Symbols

In addition to the built-in symbols, you can add your own custom symbols from graphics files in SVG, PNG, GIF, or JPEG formats. Custom symbols are saved inside the Flying Logic document, so you can be sure that anyone to whom you send a Flying Logic document will be able to see your custom symbols without having a copy of the original image file.

- Click the icon in the symbol popup menu.
- From the file chooser dialog that appears, select a SVG, PNG, GIF, or JPEG (JPG) document.
- A dialog appears that lets you select a part of your image to use as the symbol. Adjust the cropping rectangle and click the Accept button.
- Your custom symbol(s) appear at the end of the built-in symbols list in the symbol popup, and you can then assign them to entities (or classes) the same way you use the built-in symbols.
Tip: Small, simple images look best, and SVG (Scalable Vector Graphics) symbols look sharp at any zoom level or print resolution.

Managing Custom Symbols

Select Entity ➤ Manage Custom Symbols to display a dialog that lists all of the custom symbols embedded in your document, and also provides options for adding additional symbols, seeing which symbols are currently in use, and removing symbols from your document. Flying Logic will warn you if you attempt to remove a symbol that is currently in use.

Working With Edges

In Flying Logic, entities are connected to one another by causal relationships represented by edges. Each edge has a direction indicated by its arrowhead. In the way a Flying Logic document is set up by default, each edge represents the principle of sufficient cause. In other words, the existence of the state of affairs described by the entity at the tail of the arrow is sufficient to cause the state of affairs described by the entity at the head of the arrow. For a discussion of other possible ways to set up the meaning of edges, see “Operators” on page 59.

“is sufficient to cause”

When there are two or more sufficient causes of an entity, then two or more edges point to it. The meaning here is that either OR both of the causes being true makes the effect true.
Creating Edges

To create an edge between entities, click and drag from the cause to the effect. While you drag, a distinctive gesture arrow appears to confirm that you are creating a connection.

Like other graph elements, edges may have annotations attached to them.
Parallel Edges

Flying Logic disallows *parallel edges*— in other words, more than one edge from a particular cause to a particular effect.

Back Edges

Flying Logic supports **back edges** (also called *cyclic edges* or *loops*), which are edges that (directly or indirectly) make an effect to be its own cause. When a connection is made that requires a loop, a back edge is created automatically. Back edges are thicker than regular edges.

Unlike regular edges, back edges do not participate in calculations—confidence values do not flow through them and their weights are ignored. They can be annotated like any other edge. Supporting back edges allows relationships such as *virtuous and vicious circles* to be diagrammed, while keeping the basic model a *directed acyclic graph*. 
Moving Edges

As you build your diagram, you will often discover that the head or tail of an edge needs to be moved to a different entity (or junctor). This is easily accomplished by clicking and dragging near the end of the edge you want to move and dropping over the entity (or junctor) where you want to reconnect it. Before you click, you will see a highlight appear near the end of the edge that you will be moving. While you drag, a distinctive gesture arrow with a circular head appears to confirm that you are moving an edge. You can also drop over another edge, which will cause a new junctor to be inserted on that edge.

Reversing Edges

Edges normally point from causes to effects. If you discover that your document has an edge pointing “backwards” from an effect to a cause, this can easily be fixed by reversing the edge. All currently selected edges can be reversed with the Edit ➤ Reverse Selected Edges command.
mand. Note that “reversal” here refers to swapping the elements at the head and tail of an edge, and not to the direction the edge points, which is usually determined by the Orientation popup of the Layout Inspector.

Swapping Elements

You can also swap any two elements of the same kind with the Edit > Swap Selected Elements command. This command simply causes the two selected elements of the same kind (entities, junctors, edges, or groups) to switch places, including any attributes such as annotations, edge weights, or group color.
Swapping Forward and Back Edges

When you are creating diagrams that involve back edges, it is sometimes nice to be able to choose which edge in a loop should flow against the direction of the rest of the document. You can accomplish this by selecting a back edge and a forward edge, then choosing the `Edit ➤ Swap Selected Forward and Back Edges` command.
Working With Junctors

Frequently, effects are brought about only by the several causes in combination. **Junctors** are small circles that contain the name of an **operator** such as AND or OR. Since more than one edge entering an entity is, by default, already considered to be an OR operation, junctors are often used to represent AND, which is the idea of **necessary condition**: that several causes are each necessary but none of them alone is sufficient.

Creating Junctors

As we’ve seen, creating edges is as simple as dragging from cause to effect. Creating junctors is equally simple: drag from the cause to the edge where the new junctor should appear. You can also right-click (Mac, Windows, Linux) or Control-click (Mac) an edge and select an operator type from the Insert Junctor section of the popup menu.
Entities, Junctors, and Edges

There is a difference between how entities and junctors are related to the edges that connect them. The existence of entities is *independent* of their edges, while the existence of junctors is *dependent* on their edges. That is, an entity can exist whether or not it is connected to any other part of the diagram: it may have edges entering it or leaving it, or both, or it may be unconnected to anything. On the other hand, junctors must always have at least one edge coming in and one edge going out—if the last edge either entering or leaving a junctor is removed, the junctor itself will also be automatically removed.

Working With Groups

Groups help you organize your diagram and manage the complexity of larger diagrams. Groups appear as shaded rectangles that enclose entities, junctors, and other groups. Like entities, groups may have both titles and annotations, which are edited in exactly the same ways as for entities.

Creating Groups

You can create groups using the **Entity ➤ New Group** command, or by clicking the New Group button on the toolbar.

- If there is no selection, the new group will be created by itself outside all other groups.
- If there is a selection, the new group will enclose every element in the selection.
Setting the Group Title

To change the title of a group: double-click it, edit the text in the field that appears, then click outside the field to finish the change.

Arranging Grouped Elements

Individual elements and selected sets of elements can be moved into, out of, and between groups by dragging. First, select the elements you wish to move to a different group. Then drag any of the selected elements into the new group. While you drag, a distinctive gesture arrow with a square head appears to confirm you are rearranging objects within groups. Groups can also be nested within other groups using this technique, and you can also move elements out of any group by dragging to the gray canvas background.

Moving Elements Into a Group

Collapsing and Expanding Groups

Groups can be collapsed (or expanded) to hide (or reveal) their enclosed elements.

- To collapse (or expand) a group, click the small triangle that appears in its upper-left corner. Option-click (Mac) or Alt-click (Windows) to collapse (or expand) all nested groups within the group as well.
- The Group Tab of the Element Inspector contains four buttons

Tip: Any combination of dragging from entities, edges, or junctors to other entities, edges, or junctors will result in a new connection being made, as long as it would not result in a parallel edge. If the start or end (or both) of the drag is an edge, a new junctor will be inserted there and the new edge connected to it.

Tip: Preconditions are causes that are outside of your control, while Actions are causes inside your control. For more information about the entity classes used in these examples, see the accompanying document, Thinking with Flying Logic.

Entities, Junctors, and Edges

There is a difference between how entities and junctors are related to the edges that connect them. The existence of entities is independent of their edges, while the existence of junctors is dependent on their edges. That is, an entity can exist whether or not it is connected to any other part of the diagram: it may have edges entering it or leaving it, or both, or it may be unconnected to anything. On the other hand, junctors must always have at least one edge coming in and one edge going out— if the last edge either entering or leaving a junctor is removed, the junctor itself will also be automatically removed.

Working With Groups

Groups help you organize your diagram and manage the complexity of larger diagrams. Groups appear as shaded rectangles that enclose entities, junctors, and other groups. Like entities, groups may have both titles and annotations, which are edited in exactly the same ways as for entities.

Creating Groups

You can create groups using the Entity ➧ New Group command, or by clicking the New Group button on the toolbar.

• If there is no selection, the new group will be created by itself outside all other groups.
• If there is a selection, the new group will enclose every element in the selection.
that explicitly perform the above operations: **Collapse, Expand, Deep Collapse, and Deep Expand**

When a group is collapsed, any edges connected to elements both inside and outside the group appear to be attached to the group. Expanding the group will show the actual point of attachment.

![A Collapsed Group](image)

**Group Colors**

The Group tab of the Element Inspector contains a popup menu that lets you select the color of the currently selected group(s). This can be useful as a way of visually identifying or categorizing groups.

**Assigning Symbols to Groups**

Like entities, groups can also be marked with a symbol. Select one or more groups then select the desired symbol from the Icon Popup in the Group tab of the Element Inspector. To remove a symbol, select the 🚫 icon in the upper-left corner of the popup.
**Hoisting**

**Hoisting** views the contents of a single group as the entire contents of the canvas, as if it had been raised (hoisted) up to the top level. Hoisting makes it much more convenient to work on parts of documents that are nested within groups, even down several levels.

In the following illustration, we wish to work purely inside Group 2. To do so, select the group then the **Group ➤ Hoist Selected Group** command. After hoisting, the canvas only contains elements from within Group 2, as well as edges that enter or leave it along with icons representing the entities at the other end of those edges. The icons cannot be edited, and in fact they are part of the entering or leaving edge itself.

Let’s say that after editing Group 2 for awhile, we need to see its contextual parent group, Group 1, but we’re not yet ready to unhoist all the way back to the top. Selecting the **Group ➤ Unhoist One Level** command accomplishes this.

To return to the top level at this point, we could either select the **Group ➤ Unhoist One Level** command again, or use the
**Group ➧ Unhoist to Top** command, which would return us to the top level no matter which group was previously hoisted.

When a group is hoisted, the **Path Bar** appears along the top of the canvas, indicating how many levels deep you are viewing, and the names of the groups you must traverse to get back to the top level:

```
Top ➧ Marketing Dept. ➧ Office of the Marketing VP
```

Clicking any segment of the Path Bar to the left of the last one unhoists to that level in a single step.

**Tip:** Flying Logic does not save the current hoisting level in the document file. Therefore, each time you open a document Flying Logic will show the entire document, even if it was saved while a group was hoisted.

**Tip:** Printing or exporting a Flying Logic document in image formats such as JPG, PNG, or PDF takes into account the groups you have collapsed and the currently hoisted group, if any, along with your other layout settings. In other words, what you see before you export or print is what you will get in the resulting output. Exporting in non-image formats like Microsoft Project or OPML always exports the entire document.

**Selections**

Flying Logic lets you select several diagram elements upon which to perform operations.

- You can select an individual element by clicking it.
- You can use the arrow keys to move the selection from element to element.
- Additional elements can be selected (or deselected) by Shift-clicking.
- Holding down the Shift key and pressing the arrow keys “expands” the selection in the direction you specify.
- **Marquee selection** can be used to select several elements with
one gesture. Option-click (Mac) or Control-click (Windows or Linux) in the gray background area of the graph and drag the selection rectangle over the elements you wish to select. Additionally, starting marquee selection with Shift-Option-click (Mac) or Shift-Control-click (Windows or Linux) will toggle the selected/not-selected state of the objects you drag over. If you begin your marquee selection inside a group, only elements within that group are eligible for selection.

Deleting Selections

All selected elements can be deleted by pressing the Delete key, or by clicking the Delete button in the toolbar. Like all Flying Logic actions, deletion is undoable.

**Tip:** Deleting a group does not automatically delete any enclosed elements (unless they are also explicitly selected.) Instead, the enclosed elements are “promoted” to the next higher group, if any. Deleting a selected group along with all its enclosed elements (including other groups) can be accomplished by pressing Command-Delete (Mac) or Control-Delete (Windows).
Copy and Paste

Selected elements can be cut, copied, and pasted within and between Flying Logic documents. When you make a selection and select the Edit ➤ Copy or Edit ➤ Cut command, or click the corresponding toolbar icons, the selection becomes shaded orange (for copy) or red (for cut). You can cancel a pending Copy or Cut any time by pressing Escape. Once you have a shaded selection, select the group (or no group at all) in any document you wish to transfer the elements to and select Edit ➤ Paste or click the Paste toolbar icon.

![Copied Elements](image)

Layout

Your job is to make a diagram that accurately models your problem. Other than a few simple choices, such as whether your diagram flows from bottom-to-top or left-to-right, working out how the various graph elements are laid out is purely Flying Logic’s job. Sometimes Flying Logic may surprise you by making layout choices different from those you might have made, but it will often make better choices than most people, especially when the graph becomes complex. Each time you change the structure of the graph, Flying Logic uses animated transitions to show you what has changed. You can control the speed of the animation. See “Preferences” on page 99.
Orientation

Flying Logic documents “flow” in a direction specified by the Orientation Popup of the Layout Inspector. Which you choose for your diagram depends on the usual flow for the kind of diagram you are creating, compactness, or simply which one looks best to you.

If you find yourself using one orientation for new documents, you can select the default orientation used by new documents. See “Preferences” on page 99.

Side-To-Side Orientations

Use the side-to-side orientations for diagrams that naturally represent dependency flows.
Radial Orientations

Use the radial orientations for diagrams that naturally represent trees or parts explosions.

**Tip:** Radial orientations work best when the diagram is a true tree— that is, where each “parent” entity may have multiple “children”, but where each “child” may only have a single “parent”. Whether you choose Inner To Outer or Outer to Inner depends on whether you want arrows pointing outward or inward with respect to the center of your diagram.

**Tip:** Changing Orientation does not change which entities are at the head and tail of edges: if you need to reverse edges in one step, simply use the Edit ➧ Reverse Selected Edges command.
Bias

The layout bias of a document tells Flying Logic whether to prefer pushing elements closer to the start of the flow, or closer to the end of the flow. Which you choose can strongly impact the style of your diagram.

Incremental Layout

Each time you change your document, Flying Logic lays it out again in order to keep the diagram compact and minimize edge crossings. Normally, Flying Logic performs a full, “from scratch” layout of your diagram, which results in a highly efficient and clear result. However, this full layout does not take into account the starting position of the graph elements, and therefore can sometimes cause a large amount of visual change, even causing the entire diagram to appear to flip over. These large shifts can make it hard to follow even small changes, and the larger the diagram, the worse the problem. In the following illustration, a full layout after connecting F to A results in F and D switching places, as well as C and E.
By turning on Incremental Layout using either the toolbar icon or the View ‣ Incremental Layout command, you tell Flying Logic that you want to have each layout depend on the results of the previous layout. In the following illustration with Incremental Layout on, the relative positions of all the entities stay mostly the same.

![Incremental Layout On](image)

The advantage of Incremental Layout is that you can make a large number of changes to your document with a minimum visual disturbance. The downside is that with Incremental Layout on, the layout will get progressively less efficient, particularly in its use of space. When it is convenient, you can turn off Incremental Layout to cause Flying Logic to do a full layout.

**Tip:** Flying Logic does not save the position of a document’s elements (the result of the layout) in the document file. Therefore, each time you open a document, Flying Logic will perform a new, full layout, even if it was saved while Incremental Layout was on.
Managing Large Documents

Keep the following guidelines in mind when working with large Flying Logic documents.

Managing Memory

Flying Logic provides a Memory Gauge to the right of the Title Editor in each document window that shows the amounts of memory in use (dark blue) currently allocated to Flying Logic (medium blue) relative to the maximum the application will ever request (light blue).

As you work, the dark blue bar will rise and fall again as Flying Logic reclaims unused memory. As your document becomes larger, the medium blue bar will also grow, but will never get smaller until you restart Flying Logic. Memory only becomes a serious consideration when the dark blue bar starts occupying the entire width of the Memory Gauge most of the time. If this happens, try closing unnecessary documents or restarting Flying Logic.

Managing Graphic Complexity

You may notice that Flying Logic redraws, animates, or responds to user actions more slowly when a diagram becomes large and complex. Here are some ways to mitigate this:

- Use groups to enclose parts of your diagram you’re not working on, and then collapse those groups. Collapsed groups are fast to draw and can contain any number of diagram elements.

- Use the Zoom control to display less of the diagram at one time.

- **Experiment with the Display Animation Preferences settings.** See "Preferences” on page 99.

- Consider breaking your diagram into two or more sub-diagrams in separate documents.
Graph Logic

Flying Logic provides tools for you to test and work with the logic of your diagrams.

Confidence Spinners

By selecting the View ➤ Confidence command or clicking the Confidence toolbar icon, each entity reveals a small circle called a spinner. Confidence spinners represent a single numeric value that can be thought of as a percentage from 0% to 100% (0.0 to 1.0). You can use Flying Logic’s preferences to choose whether spinners are displayed with shading only (no symbol), a numeric value from 0 to 100, or a symbol, which for confidence spinners displays F (false) for 0%, T (true) for 100%, and shading only for other values. See “Preferences” on page 99.

Setting Confidence Values

Entities that have no incoming edges are drivers, and the value of their confidence spinner can be changed directly by clicking and dragging on the spinner. Entities that have one or more incoming edges are driven, and their confidence value is purely the result of how their inputs are combined. Spinners of driven entities are bordered by a gray circle, and dragging on them has no effect. For drivers, you can drag right or up to increase the spinner’s value, and left or down to decrease it. As you drag, all driven entities affected by your changes are updated simultaneously.
You can also hold down the Shift key while dragging to constrain the spinner’s value to increments of 5%, and (while the mouse button is still down) use the arrow keys on your keyboard to “nudge” the spinner’s value up or down in 1% increments.

Finally, you can use keypresses to change the confidence values of all selected driver entities. Pressing the ‘1’ key through the ‘9’ key changes the confidence values from 10% to 90%, while pressing the ‘T’ key (for True) changes it to 100%, pressing the ‘F’ key (for False) or ‘0’ (zero) key changes it to 0%, and pressing the ‘U’ key (for Unknown) changes it to 50%.

**The Meaning of “Confidence”**

Confidence is simply a numeric value, but what it actually means is subject to the needs of your project and the operators you use to manipulate it. In the way Flying Logic documents are set up by default, the confidence value can be thought of as your level of confidence that the state of affairs described by a given entity holds. If the spinner is 0% shaded then you are expressing absolute certainty that the entity does not hold (logical False.) If the spinner is 100% shaded then you are expressing absolute certainty that the entity does hold (logical True.) If the spinner is 50% shaded, then you are expressing a logical Indeterminacy which could mean either no opinion or conflicting opinions about whether the entity holds.
Tip: There is a useful distinction between having no opinion and having conflicting opinions on a subject, although Flying Logic does not currently support modeling that distinction. In the case of having no opinion, you are asserting neither truth nor falsehood. In the case of having conflicting opinions, you are asserting both truth and falsehood. There are mathematically valid ways of representing such paraconsistent logic that Flying Logic may support in the future. For typical applications, it is usually most useful to think of confidence values of 50% as meaning no opinion.

Probability vs. Fuzziness

It is important to understand that in the way Flying Logic documents are set up by default, confidence values represent fuzzy boolean values, not probabilities. The basic distinction to remember is that probabilities deal with the uncertainty or likelihood of whether something may occur, while fuzzy logic (from which fuzzy booleans derive) deals with ambiguity or vagueness about what has, or has not, occurred. The following statement is probabilistic:

The water in the pot may get hot.

...While the following statement is fuzzy:

The water in the pot is hot enough.

Combining probabilities is done using multiplication, as in the case of determining the probability of two coin flips both coming up heads (50% × 50% = 25%). To combine fuzzy statements you use fuzzy AND, OR, and NOT operators, which correspond to mathematical minimization, maximization, and complement. (“hot water” AND “steep tea bag” SUFFICIENT FOR “hot tea”). So far we have seen examples of AND and OR. See “Edge Weights” on page 64 for a discussion of fuzzy NOT. See “Operators” on page 59 for a discussion of how to set up Flying Logic documents for probabilities.

Operators

Confidence values flow through the entities, edges, and junctors of a Flying Logic document, being modified along the way by the operators they encounter. This section discusses the operators found on entities and junctors—edges also perform a weighting function discussed in
**Numeric Data Types**

Confidence values are represented as one of two data types: *fuzzy boolean* or *floating-point*. The primary difference between the two types is that fuzzy booleans are restricted to the range 0.0 to 1.0, while floating-point values are not. Some of the operators in this section are primarily for use when dealing with fuzzy booleans, some are primarily for dealing with floating-point values, and some work just as well with either. Generally, if the result of an operation is outside the range of a fuzzy boolean, it will automatically be converted to a floating-point value. Flying Logic displays different kinds of edge arrowheads depending on whether a fuzzy boolean or floating-point value is flowing through it.

**Tip:** For now, all numeric input and output in Flying Logic is handled by spinners, which can only handle the range 0.0 to 1.0 (for confidence values) or -1.0 to 1.0 (for edge weights.) It is expected that a future version of Flying Logic will incorporate more data types and additional methods for their input and output.

In the above example, the results of the Sum junctor are 1.25, and since this value is out of the fuzzy boolean range, the arrow leaving the Sum junctor has an open arrowhead, indicating a floating-point value.
This value cannot be displayed by confidence spinners, and as a result the spinner of entity C turns red. However, the correct value is propagated, as seen from the results of the Product junctor displayed in entity E.
Basic Operators

The Basic Operators are sufficient for creating diagrams that support the TOC Thinking Processes.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fuzzy And (AND)</td>
<td>Returns the minimum of its inputs. Inputs are interpreted as “necessary conditions.” Output value is always fuzzy boolean.</td>
</tr>
<tr>
<td>Fuzzy Or (OR)</td>
<td>Returns the maximum of its inputs. Inputs are interpreted as “sufficient causes.” Output value is always fuzzy boolean.</td>
</tr>
</tbody>
</table>

Advanced Operators

The Advanced Operators are used to support modeling using probabilities and other advanced applications.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fuzzy Exclusive Or (XOR)</td>
<td>For output to be true, exactly one input must be true. Inputs are interpreted as “sufficient but mutually exclusive causes.” Output value is always fuzzy boolean.</td>
</tr>
<tr>
<td>Proportion (∷)</td>
<td>Treats each input as a “vote” of a strength proportional to the confidence value and the edge weight. Edge weights of zero count as abstentions and do not affect the output, which is different from a simple average where each zero input tends to reduce the output. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Sum (+)</td>
<td>Returns the sum of its inputs. Output value is fuzzy boolean unless at least one input is floating-point or the sum is outside the range of a fuzzy boolean, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Sum Probabilities (⊕)</td>
<td>Follows the Specific Addition Rule, also called the OR rule. Useful for calculating the probability of two or more independent events causing a particular outcome. For example, the probability of one OR both of two flipped coins coming up heads is 50% ⊕ 50% = 75%. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Product (×)</td>
<td>Returns the product of its inputs. Often used to determine the probabilities of two or more independent events occurring together (the Specific Multiplication Rule, also called the AND rule.) For example, the probability of a first AND second coin flip both coming up heads is 50% × 50% = 25%. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Operator</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reciprocal (1/n)</td>
<td>Returns the reciprocal of its input. Output value is always floating-point. Often used to implement division by way of $a / b = a (1 / b)$. If more than one input is present, returns the reciprocal of the sum of its inputs.</td>
</tr>
<tr>
<td>Negate (-n)</td>
<td>Returns the negation of its input. Output value is always floating-point. If more than one input is present, returns the negation of the sum of its inputs.</td>
</tr>
<tr>
<td>Complement (1-n)</td>
<td>Returns the complement (1-n) of its input. Output value is fuzzy boolean unless at least one input is floating-point or the sum is outside the range of a fuzzy boolean, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Minimum (MIN)</td>
<td>Returns the minimum of its inputs. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Maximum (MAX)</td>
<td>Returns the maximum of its inputs. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Average (AVG)</td>
<td>Returns the average of its inputs. Output value is fuzzy boolean unless at least one input is floating-point, in which case the output is floating-point.</td>
</tr>
<tr>
<td>Distributor (☼)</td>
<td>The distributor behaves exactly the same as the Sum (+) operator, but is intended as a convenience for situations where a single input value is to be distributed to several outputs in a location of the diagram far away from where the value was originally produced.</td>
</tr>
</tbody>
</table>

**Junctors Operators**

The purpose of junctors is to combine several inputs into an output value using an operator. The name of the operator is displayed on the junctor itself, and is by default Fuzzy And (AND).

Each junctor in a diagram can use a different operator, and the operator that new junctors are created with is set using the Default Junctor Operator popup in the Operators Inspector.

To change the operator of an existing junctor, use one of the following options:

- Select the junctor, then select the desired operator from the Operator Popup in the Junctor Tab of the Element Inspector.
- Right-click (Mac, Windows, Linux) or Control-click (Mac) the junctor and select the desired operator from the popup menu.
Entity Operators

All entities in a diagram have an operator used to combine the confidence values from their incoming edges. By default this operator is Fuzzy Or (OR).

Unlike junctors which can each have a different operator, all entities in a given document have the same operator, which is set using the Entity Operator popup in the Operators Inspector.

Tip: Selecting a new Default Junctor Operator only affects junctors created after the change, but selecting a new Entity Operator immediately changes the operator used by all entities in the diagram.

Setting up for Probabilistic Analysis

Usually you will make selections from the Entity Operator and Default Junctor Operator popups in the Operators Inspector just once when you begin building a diagram. If you are building a diagram using a fuzzy methodology such as Effects-Based Planning, the entity operator Fuzzy Or (OR) and the default junctor operator Fuzzy And (AND) will usually be fine (these are the document defaults.) If you are using a probabilistic methodology such as Evidence-Based Analysis, a common setup is to have Sum Probabilities (⊕) as the entity operator and to have Product (×) as the default junctor operator. This setup is analogous to the use of OR and AND in the default (fuzzy) setup. In cases where you are evaluating a belief network and wish to use a more intuitive vote-like setup, you will usually set both the entity operator and default junctor operator to Proportion (∷).

Edge Weights

Just as each entity carries a confidence value, each edge carries a numerical edge weight value. When visible, each edge displays a spinner that indicates its weight.

Edge weights can be displayed for every edge in the diagram, or only for selected edge weights. To show weights for every edge, select the View ➤ Edge Weights command or click the Edge Weights toolbar icon. To display weights for only selected edges, select the edges you desire and then use one of the following options:
• Select the Edge Weight Visible checkbox in the Edge Tab of the Element Inspector.

• Right-click (Mac, Windows, Linux) or Control-click (Mac) any of them and select the Show Selected Edge Weights command from the contextual menu.

**Tip:** The setting for the View ➤ Edge Weights command overrides the settings for showing individual edge weights. When it is turned on, all edge weights will be visible and the individual settings for edges are ignored.

Edge weights can be thought of as percentages from $-100\%$ to $100\%$. Negative weights are represented as red, and positive weights are green. A weight of exactly zero is represented as yellow. The same preference that selects what kind of symbol to display inside of Confidence spinners also controls the symbol displayed inside edge weight spinners. Another preference lets you decide how the color of the edge itself corresponds to the edge weight. By default, edges with positive weights are black, edges with negative weights are red, and edges with zero weights are gray. See “Preferences” on page 99.
In the belief network illustration above, the confidence values of the Knowledge entities represent the strength of belief in each statement, while the edge weights represent the correlation between the knowledge items and the propositions under consideration. The resulting values are combined using the Proportion (∷) operator.

**Setting Edge Weight Values**

Unlike confidence spinners, there is no “driver/driven” distinction with edge weights—every edge weight may be adjusted independently of all the others. Clicking and dragging on edge weight spinners works the same way as it does for confidence spinners, as does holding down the Shift key to constrain changes to increments of 5%.

You can also use keypresses to change the edge weight values of all selected edges. Pressing the 1 key through the 9 key changes the weight values from 10% to 90%, while pressing the – (minus) key changes it to −100% (logical negation or negative correlation), pressing the + key changes it to 100% (positive correlation), and pressing the 0 (zero) key changes it to 0% (no correlation).

**The Edge-Weighting Function**

The edge-weighting function is illustrated below. For floating-point values, the result is a simple multiplication. For fuzzy boolean values, the calculation is slightly different. In the case of a simple multiplication, a 100% confidence value (True) multiplied by a 0% edge weight would yield a 0% result (False). What should happen is that a true assertion given no weight should yield an Indeterminate result (neither True nor False). To accomplish this, Flying Logic temporarily converts fuzzy boolean values into the range -100%...100% (like edge weights) multiplies the two values, and then converts the results back into the fuzzy boolean range 0%...100%, which yields the desired result.
Logical Negation

Edge weights are often used in the probabilistic context of Evidence-Based Analysis. But they are also useful in Effects-Based Planning to represent fuzzy NOT (logical negation.) Even without revealing the edge weight spinners, you can right-click (Mac, Windows, Linux) or Control-click (Mac) an edge and select a positive (+), neutral (0) or negative (−) edge weight from the popup menu that appears. For fuzzy boolean values, negative edge weights represent the logical negation of the input. For more information about Effects-Based Planning and Evidence-Based Analysis, see *Thinking with Flying Logic*.
Domains

Classes and Domains

Each entity you create is assigned to an entity class (or just class.) Entity classes are a purely visual reminder of the “kind” of each entity: Flying Logic does not in any way restrict the kinds of connections an entity may have based on its class. That said, the methodology you choose or problem domain in which you work may place restrictions on what classes of entities may be connected. For instance, in Effects-Based Planning, Precondition and Action entities should always be drivers (have no incoming edges) while Intermediate Effect and Goal entities should always be driven (have at least one incoming edge.)

![Entity Classes Diagram]

Working with Classes

To create entities with a chosen class, see “Working With Entities” on page 24.

To select all entities of a chosen class, Shift-double-click the class in the entity Domain Inspector. To change all selected entities to a chosen class, Alt-double-click (Windows or Linux) or Option-double-click (Mac) the class in the entity Domain Inspector. The last two tasks may be performed in sequence to change all entities of one class to another.

Classes are grouped into domains. Domains are used to contain the classes used for creating diagrams in a particular problem domain or using a particular methodology. Double-clicking a domain icon will collapse or expand that domain. Flying Logic has five built-in domains, which cannot be modified, and which are described in the accompanying document Thinking with Flying Logic:

- General, which contains two classes, Generic and Note
- Effects-Based Planning
Creating Custom Classes

Although Flying Logic’s built-in classes are useful for many general purposes, in your field you may have particular classes you need to work with. Flying Logic allows you to create the domains and classes you need, and re-use them in the documents you create. Because the built-in domains and classes are not modifiable, before you can create any custom classes you must create at least one custom domain.

Creating A Custom Domain

1. Select the Domain ➞ New Domain command, or click the New Domain button at the bottom of the Domain Inspector. The custom domain is created and added to the class list, and the Edit Domain dialog appears.

2. Type a name for the new domain and click the dialog’s close box.

Creating A Custom Class

1. In the Domain Inspector, select one of the custom domains you have created in which you want the custom class to appear, or the existing custom class after which you want the new custom class to be added.

2. Select the Domain ➞ New Class command, or click the New Class button at the bottom of the Domain Inspector. The custom class is created and added to the selected domain, and the Edit Class dialog appears.
3. Type a name for the new class, select a color for the class from the color chooser, and if desired select a default icon to appear on all entities of that class from the Icon Popup in the Edit Class dialog.

4. Choose whether you want entities of this class to display the class name in a colored stripe at the top of the entity rectangle. If you turn off Show Name, entities of this class will appear with no class name and their entire background will take on the color of the class.

5. If you will be enabling the project management feature, you may want to choose whether an entity based on this class is a milestone (zero effort) and how resources are assigned.

6. Click the dialog’s close box. You can now use the new class in your diagram just as you use the built-in classes.

**Changing Existing Domains and Classes**

To change the name of an existing custom domain or the name, color, or icon of an existing custom class, select the domain or class and click the
Inspect button at the bottom of the Domain Inspector.

Tip: If you change the icon of a class, and all the existing entities of that class do not change their icon to match, then those entities have had their icon “overridden” by the setting of the Icon Popup menu. To correct, select the entities and then select the icon from the Icon Popup in the Entity tab of the Element Inspector. For more information, see “Assigning Symbols to Entities” on page 35.

To delete a custom domain or class, select the domain or class to be deleted and click the delete button at the bottom of the Domain Inspector.

You can also drag entity classes to re-arrange them within or between domains.

Exporting and Importing Domains

Frequently you will want to re-use the custom domains you create across many documents. Flying Logic supports exporting custom domains, as well as importing custom domains and the classes they contain.

To export a domain, select it in the Domain Inspector, then select the Entity ➤ Export Selected Domain command. The domain file will be saved in the location you specify.

To import a domain, select the Entity ➤ Import Domain command, and choose the domain file you wish to import. The category and its classes are added to your document.

You can also create a new, blank document with an exported domain already available by selecting the domain file in the dialog presented by the File ➤ Open command, or by double-clicking the domain file in your desktop environment.

Tip: You can only export or import an entire domain and all of its classes—you cannot export or import individual classes.
Resolving Conflicts When Importing

Each custom entity class carries a unique, hidden identifier that is created when the class is created, and that never changes even when the name or other attributes of the class changes. These identifiers are exported along with each custom class in the exported category. When a category is imported, a check is done to determine whether any of the identifiers of the classes being imported conflict with the identifiers of the classes already in the document. If any do, it is assumed that an updated version of the category is being imported, and the names and colors of the classes being imported override those already in the document. A notification is provided to you when this occurs, and if the results are not what you expect, you can use the Undo command to revert to the state of your document before the import.

Hiding Domains

Flying Logic documents often combine entities of classes across several domains. However, there are times you’d rather not see one or more built-in or custom domains in the Domain Inspector. You can hide such domains easily, and your choices of hidden domains are saved along with your document:

- Uncheck the name of the domain to be hidden in the **Domain ➤ Domain Visibility** submenu, or...
- In the Domain Inspector, right-click (Mac, Windows, Linux) or control-click (Mac) the domain and select the **Hide Domain “Name”** command from the popup menu.

To show a previously hidden domain:

- Check the name of the domain to be shown in the **Domain ➤ Domain Visibility** submenu.

To save all currently visible domains (and all hidden domains) as the default for new documents:

- Select **Domain ➤ Save Domains as Defaults**.

This command also gives you the option to restore the list of visible domains to the factory defaults.
Chart View

The diagrams created in Flying Logic can be displayed in a second way called Chart View. This view is activated for a document by selecting the View ➤ Switch to Chart View command, which changes to Switch to Graph View when Chart View is active. In this mode each entity, junctor, and group is shown as one row of a chart. The top-most row displays the entity or group that would appear at the top of a Top-to-Bottom layout in Graph View, while the bottom-most row displays the entity or group that would appear at the bottom.

Each row is divided into two parts. On the left are a series of columns containing information about the element in that row. On the right is the actual display of that element, similar to Graph View.

The set of columns to be shown can be modified based on both document-wide settings (like Confidence), while others can be selected by using the context menu for the column header row (like Entity Class). The width of the entity title and class columns can be changed by dragging the separator line at the right of the column in the Chart View header.

The elements in the diagram can be manipulated in Chart view just like in Graph view, including selecting, reconnecting, and moving elements between groups. Inline editing of entity titles can be activated by double-clicking on an entity, and all context menus are available.

As the result of the density of edges in the diagram in Chart view, only one selected edge has its weight and annotation shown at a time. These appear in an Edge Info box that floats next to the edge. The weight can be manipulated just as in graph view, and a tooltip will appear when the mouse cursor is over the annotation icon. The box does not appear if the edge has no visible weight or annotation.

Additional columns and diagram features appear when Project Management is enabled. See “Appendix A– Project Management” on page 103.
Scripting

Flying Logic includes a powerful scripting system based on the Python™ programming language. Scripts can be used to create or manipulate Flying Logic documents, and create importers and exporters that allow foreign file types to be loaded and saved directly from within Flying Logic.

Most of the details of how the built-in Python interpreter interacts with Flying Logic are detailed in a separate document: the Flying Logic Scripting Guide. This section describes only the basic scripting features and commands.

Note: Currently Flying Logic has no integrated code editor for scripting. Therefore, you will write your script files (ending with the “.py” extension) using an external text editor or programming environment, and then provide them to Flying Logic for execution.

Running a General-Purpose Script

To run a general-purpose script that either creates a new Flying Logic document or performs operations on the frontmost open document, use the Edit ➤ Run Script ➤ Open Script… command. For your convenience, the last four scripts run are remembered in the Run Script submenu.

Importing via Script

To convert a foreign file format to a Flying Logic document via a script-based importer, use the File ➤ Import ➤ Import Via Script ➤ Open Script… command. For your convenience, the last four importers run are remembered in the Import Via Script submenu.

Exporting via Script

To convert the frontmost Flying Logic document to a foreign file format via a script-based exporter, use the File ➤ Export ➤ Export Via Script ➤ Open Script… command. For your convenience, the last four exporters run are remembered in the Export Via Script submenu.

User-Defined Attributes

The User-Defined Attributes inspector (see “User-Defined Attributes Inspector” on page 21) is used manage custom name-value pairs in any
Flying Logic document element or in the document itself. This data can be accessed or modified directly from scripts.
Menus

Application Menu (Mac)

- **About Flying Logic**
  Displays version information and credits.

- **Preferences...**
  Displays the Preferences dialog. See “Preferences” on page 99

- **Quit Flying Logic**
  Quits Flying Logic. The user is prompted to save changes to any unsaved documents before quitting.

File Menu

- **New Document**
  Creates a new, blank document.

- **New Document From Selection**
  Creates a new document containing copies of any elements that were selected in the current document.

- **Open...**
  Opens an existing document. New documents can also be opened by dragging a Flying Logic document to the application icon (Windows: in Windows Explorer, Mac: in the Finder or Dock, Linux: see your window manager documentation.)

  Template files can also be opened, which open as new Untitled documents containing the contents of the template.

  Existing exported domain files can also be opened, which causes a new, blank document to be created with the domain automatically imported.

- **Open Examples...**
  Allows browsing and opening of a variety of provided example documents. Example documents open as new, untitled documents so you can modify them and save them elsewhere.
Open Recent
Select a name from the submenu to re-open a recently open document.

Close Tab
Closes the current document tab. The user is prompted to save any unsaved changes. If only one document is open in a window, this closes the document and window.

Close Window
Closes the current document window. If multiple documents are open in a window, the application attempts to close them all. The user is prompted to save any unsaved changes.

Save
Saves the current document. If the document has not been saved before, the user is prompted for a file name and folder to save to.

Save As...
Saves the current document in a new location and/or with a new name.

Save as Template...
Saves a copy of the current document in a new location with a new name, and changes its filename suffix to “.xlogic-t”. When a template file is opened, it opens as a new, Untitled document, but starts with all the content that was saved with the template.

Import Submenu

Import Diagram from CSV...
Imports a diagram from a simple CSV (comma-separated values) text document. For the format of this document, see the Flying Logic Scripting Guide.

Import from MS Project...
Imports a diagram from an MS Project document in either XML or MPX format. The diagram may include extra elements to properly represent features from MS Project. See the section Notes on MS Project Import and Export in the Project Management appendix.
Import via Script Submenu

- **Open Script...**

Executes the selected script as an importer of the current document. For more information, see X.

For convenience, the submenu also remembers the last four scripts run this way.

Export Submenu

**Tip:** Export of diagrams to PDF, PNG and JPEG now support a “Save Ink” option identical to that available when printing: group backgrounds are not shaded.

- **Export Diagram as PDF...**

Creates a PDF file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

**Tip:** PDF is the most desirable format for publishing and all other applications that do not require a “bitmapped” graphics format (such as JPEG or PNG), as PDF images will scale to any size with no loss of quality. PDF also supports transparency, and will look good when overlaid against backgrounds containing images or textures.

- **Export Diagram as JPEG...**

Creates a JPEG file with the diagram of the current document. The document is formatted as a single image large enough to contain the entire diagram.

**Tip:** JPEG images are compressed, and may show a slight fuzziness around the edges of lines and text. Also, JPEG images do not support transparency, so programs that overlay images on backgrounds (such as presentation software) will show the JPEG as completely obscuring any background. Exporting the image to PDF or PNG is recommended when transparency is desired.
Export Diagram as PNG...

Creates a PNG file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

*Tip:* PNG images use a “lossless” form of compression that does not result in the edge-fuzziness associated with JPEG images. Also, PNG images support transparency, and will look good when overlaid against backgrounds containing images or textures.

Export Diagram as Graphviz (DOT)...

Creates a file in the DOT graph description language used by the Graphviz open source graph visualization toolkit.

Export Diagram as Scalable Vector Graphics (SVG)...

Creates a Scalable Vector Graphics (SVG) file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

Export Outline as OPML...

Creates an OPML file with the diagram of the current document. OPML documents can be directly imported into many popular outliner applications.

Export Annotations as PDF...

Creates a PDF file with only the annotations in the current document. Each annotation includes its annotation number, which can be cross-referenced with the annotation numbers that appear when the View Note Numbers command is turned on.

*Tip:* Note numbers change as annotations are added and removed from the document, and should not be relied on to stay the same across document revisions.

Export Annotations as Text...

Creates a plain text file with only the annotations in the current document. Each annotation includes its annotation number, which can be cross-referenced with the annotation numbers that appear when the
**View Note Numbers** command is turned on.

*Tip:* Note numbers change as annotations are added and removed from the document, and should not be relied on to stay the same across document revisions.

 développareador

**Export as MS Project Data Interchange (XML)...**

Exports the current document in MS Project Data Interchange format, which is a format based on XML used to exchange Microsoft Project data.

See below for details on the conversion of Flying Logic documents to MS Project documents.

**Export as MS Project Exchange (MPX)...**

Exports the current document in MPX format. MPX is a native binary format used to exchange Microsoft Project data.

See below for details on the conversion of Flying Logic documents to MS Project documents.

*Note:* Export to MPX is deprecated, and is only still provided for users who must use older versions of Microsoft Project that do not import the XML format above. Certain attributes may not be exported correctly when using this command.

When exporting to MS Project, the following conversion rules apply:

- All entities are converted to MS Project Tasks of the same effort assigned in the Entity tab of the Element inspector when Project Management is turned on, or 1-day effort if no other effort has been specified. Zero-effort tasks are converted to MS Project milestones. The name of the task is the entity’s title. The “Text1” field of the task is set to “Entity”. The “Text2” field of the task is set to the entity class name. The “Number1” field of the task is set to the confidence value of the entity.

- All junctors are converted to MS Project milestones. The name of the task is the name of the junctor operator. The “Text1” field of the milestone is set to “Junctior”. The “Number1” field of the task is set to the confidence value of the junctor.

- All groups are converted to MS Project summary tasks. The name
of the summary task is the title of the group. The “Text1” field of the summary task is set to “Group”.

- All edges are converted to “finish-to-start” dependencies with no lag.
- Notes for entities, groups, and junctors become notes on the corresponding tasks. Notes on edges are not preserved, because MS Project does not support notes on task dependencies.

Export via Script Submenu

- **Open Script...**

Executes the selected script as an exporter of the current document. For more information, see X.

For convenience, the submenu also remembers the last four scripts run this way.

- **Print**

Prints the current document. The Flying Logic print options dialog appears before the system print dialog, and allows a number of choices for formatting your printed output.

Edit Menu

- **Undo**

Undoes the last action that modified the current document. Virtually every action that modifies Flying Logic documents is undoable, and multiple levels of undo are supported. You can set a preference as to how many levels of undo to support. See “Preferences” on page 99.

- **Redo**

Redoes the last undone action.

- **Cut**

Works as a typical Cut command for text.

For selections of the diagram, marks the selected elements for transfer to another document or another location in the current document. Selected elements are shaded red. See “Copy and Paste” on page 50.
Copy

Works as a typical Copy command for text.

For selections of the diagram, marks the selected elements for copying to another document or another location in the current document. Selected elements are shaded orange. See “Copy and Paste” on page 50.

Paste

Works as a typical Paste command for text.

For selections of the diagram that have previously been selected for Copy, duplicates the copied elements into the currently selected group, or the top level of the diagram if there is no selection.

For selections of the diagram that have previously been selected for Cut, moves the cut elements into the currently selected group, or the top level of the diagram if there is no selection.

See “Copy and Paste” on page 50.

Delete

Deletes the current selection.

Select All

Selects all visible elements in the diagram. Does not select, for example, elements within collapsed groups or elements outside any currently hoisted group.

Deselect

Deselects all elements in the diagram.

Select Successors

For each edge, entity, or junctor in the current selection, add to the selection every succeeding element. Useful for determining which elements can be affected “downstream” of one or more selected elements.
Select Predecessors
For each edge, entity, or junctor in the current selection, add to the selection every preceding element. Useful for determining which elements can be affected “upstream” of one or more selected elements.

Select Head Entity
Selects the entity at the head of the currently selected edge. Useful for navigating diagrams with long edges.

Select Tail Entity
Selects the entity at the tail of the currently selected edge. Useful for navigating diagrams with long edges.

Reverse Selected Edges
Reverses the currently selected edges. See “Reversing Edges” on page 40.

Swap Selected Forward and Back Edges
Exchanges the positions of a single selected forward and back edge pair. See “Swapping Forward and Back Edges” on page 42.

Swap Selected Elements
Exchanges the positions of any two selected elements of the same kind. See “Swapping Elements” on page 41.

Preferences...
Displays the Preferences dialog. (Windows and Linux only. Preferences is located in the Flying Logic menu on the Mac.)

Find...
Displays the Find dialog. This dialog can also be displayed by clicking the Find button in the toolbar.

Run Script Submenu

Open Script...
Executes the selected general purpose script.
For convenience, the submenu also remembers the last four scripts run this way.

- **Show Console**

Displays the scripting system console. Messages output by running scripts will appear in this window.

**Entity Menu**

- **New Entity**

Creates a new entity of the class selected in the Domain Inspector. See “Working With Entities” on page 24.

- **Insert Entity**

Creates a new entity of the class selected in the Domain Inspector and inserts it along the currently selected edge. See “Working With Entities” on page 24.

- **Add Entity as Successor**

When turned on, newly created entities will be automatically added as successors to a currently selected entity. When turned off, the new entities will be added as a predecessor. See “Working With Entities” on page 24.

- **Reset Confidence**

Resets all confidence values in the entire document to 50%. Useful for restarting demonstrations where all confidence values are expected to begin at 50%.

- **Renumber Entity IDs**

Assigns a new Entity ID to all entities in the order they appear in the flow of the document. This is the only command that can change the Entity IDs in the document. See “Annotation Numbers and Entity IDs” on page 30.

- **Redact Selection**

Changes all title and annotation text in the selected elements to X’s. This can be useful to remove sensitive information from a document before passing it to other parties for review.
Tip: Make sure to save an unredacted version of the document for your own use.

Redact All

Changes all title and annotation text in the current document to X’s. If you need to pass a copy of a document to the Flying Logic developers so we can see how a particular layout behaves, you can use this command to remove all sensitive information from the document first.

Tip: Make sure to save an unredacted version of the document for your own use.

Manage Custom Symbols...

Displays the Manage Custom Symbols dialog, which allows you to review, add, or delete custom symbols from the document. See “Managing Custom Symbols” on page 37.

Group Menu

New Group

Creates a new group that encloses the currently selected elements. See “Creating Groups” on page 44.

Collapse Selected Groups

Collapse every selected group, but not any groups they themselves enclose. See “Collapsing and Expanding Groups” on page 45.

Deep-Collapse Selected Groups

Collapse every selected group, including any groups they themselves enclose. See “Collapsing and Expanding Groups” on page 45.

Expand Selected Groups

Expand every selected group, but not any groups they themselves enclose. See “Collapsing and Expanding Groups” on page 45.
Deep-Expand Selected Groups

Expand every selected group, including any groups they themselves enclose. See “Collapsing and Expanding Groups” on page 45.

Group Color

Changes the color of the selected groups to the choice from the submenu. See “Group Colors” on page 46.

Hoist Selected Group

Temporarily hides all document elements outside of the currently selected group. See “Hoisting” on page 47.

Unhoist One Level

Unhides all document elements in the group enclosing the currently hoisted group. See “Hoisting” on page 47.

Unhoist to Top

Unhides all document elements previously hidden by the other hoist commands. See “Hoisting” on page 47.

View Menu

Switch to Chart View / Switch to Graph View

Changes the view of the document window from Graph to Chart and back. See “Chart View” on page 75.

Confidence

Displays or hides the Confidence Spinners. See “Confidence Spinners” on page 57.

Edge Weights

Displays or hides the Edge Weights. See “Edge Weights” on page 64.

Edge Annotations

When turned on, every edge in the diagram will display a yellow box containing the text of the edge annotation instead of the small yellow bullet. Turning this option on supersedes the per-edge display of edge...
annotations. When turned on, even edges that have no annotation text will display a small yellow empty box where new text can be entered. When turned off, only edges that have the per-edge display of their annotation will display the box—others edges with annotations will display the yellow bullet. See “Annotations” on page 17.

➧ Annotation Numbers
Displays or hides the Annotation Numbers. See “Annotation Numbers and Entity IDs” on page 30.

➧ Entity IDs
Displays or hides the Entity IDs. See “Annotation Numbers and Entity IDs” on page 30.

➧ Incremental Layout
Turns on or off incremental layout mode. See “Incremental Layout” on page 53.

➧ Project Management
Displays or hides project management attributes throughout the document. See “Appendix A– Project Management” on page 103.

➧ Element Text Attributes...
Displays the Element Text Attributes dialog. See “Element Text Attributes” on page 31.

➧ Reveal Selection
Scrolls the currently-selected elements of the diagram into view, if they are not already visible.

➧ Zoom to Fit
Adjusts the magnification to display the entire diagram.

➧ Full Size
Adjusts the magnification to display the diagram elements at their full size.
Zoom In
Adjusts the magnification to display the diagram elements at their next largest size.

Zoom Out
Adjusts the magnification to display the diagram elements at their next smallest size.

Zoom X%
Adjusts the magnification to display the diagram elements at X% of their normal size.

Domain Menu

New Domain
Creates a new domain in the Domain Inspector. See “Creating A Custom Class” on page 70.

Duplicate Domain
Duplicates the currently-selected domain in the Domain Inspector.

Delete Domain
Deletes the currently selected domain, including all classes within the domain. All entities assigned to deleted classes are reassigned to the Generic class.

New Class
Creates a new custom class within the selected domain. See “Creating A Custom Class” on page 70.

Duplicate Class
Duplicates the currently-selected class in the Domain Inspector.

Delete Class
Deletes the currently selected class. All entities assigned to the deleted class are reassigned to the Generic class.
Import Domain
Prompts the user for a domain file to import, then adds the domain and its classes to the current document. See “Exporting and Importing Domains” on page 72. A shortcut to create a new document with a domain pre-imported is to simply open the exported domain file using the File ➤ Open command or double-click the exported domain file in your desktop environment.

Export Selected Domain
Prompts the user for the name and location of a domain file to save, and then writes the domain selected in the Domain Inspector, along with all its classes to the file. See “Exporting and Importing Domains” on page 72.

Save Domains as Defaults
After confirmation, saves the currently visible domains as the default set of visible domains for any newly created documents. Also allows restoring the default set of visible domains.

Domain Visibility
Enables any of the built-in domains to be hidden (or re-shown).

Format Menu

Font
Contains formatting options for fonts within annotation text. See “Styled Text, Hyperlinks, and Browse Lock” on page 19.

Make Plain Text
Removes all formatting from the selected annotation text. See “Styled Text, Hyperlinks, and Browse Lock” on page 19.

Edit Hyperlink
Displays the Hyperlink Properties dialog for the currently selected annotation text. See “Styled Text, Hyperlinks, and Browse Lock” on page 19.
Window Menu

 대하여

 **Inspectors**
Contains commands and keyboard shortcuts to display or hide each of the inspectors. See “The Sidebar and Inspectors” on page 11.

**Hide Sidebar**
Hides or displays the sidebar for times when a more presentation-oriented window format is desired.

**Hide Toolbar**
Hides or displays the toolbar for times when a more presentation-oriented window format is desired.

**Toggle Focus Between Sidebar and Canvas**
Changes whether the next keystrokes (such as arrow-key navigation) will be received by the sidebar or the canvas.

**List of Open Documents**
The Window menu also contains a list of currently open documents. The window for an open document may be brought to the front by selecting its name in this menu.

Help Menu

**Registration...**
This dialog is used for managing your registration information, including your license key.

**Documentation**
The items in this submenu open the *Flying Logic User’s Guide* (this document), *Welcome to Flying Logic, Thinking With Flying Logic* or the *Flying Logic Scripting Guide* in your PDF viewer.

**View License Agreement...**
Displays a dialog containing the Flying Logic License Agreement.
› View Credits...
Displays a dialog containing credits for Flying Logic.

› Visit Flying Logic Web Site
Opens FlyingLogic.com in your web browser, where you can find support for Flying Logic as well as an active community of Flying Logic users.

› Check for Updates
Uses your Internet connection to determine whether an updated version of Flying Logic is available for download.
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Normal</th>
<th>Ctrl&lt;sup&gt;M&lt;/sup&gt;/Cmd&lt;sup&gt;M&lt;/sup&gt;</th>
<th>Alt&lt;sup&gt;WL&lt;/sup&gt;/Opt&lt;sup&gt;WL&lt;/sup&gt;</th>
<th>Ctrl&lt;sup&gt;WL&lt;/sup&gt;/Cmd&lt;sup&gt;WL&lt;/sup&gt;+Shift</th>
<th>Ctrl&lt;sup&gt;WL&lt;/sup&gt;/Cmd&lt;sup&gt;WL&lt;/sup&gt;+Alt&lt;sup&gt;WL&lt;/sup&gt;/Opt&lt;sup&gt;WL&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Select All</td>
<td>View Annotations</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>Bold</td>
<td></td>
<td>View Confidence</td>
<td>New Class</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>Copy</td>
<td></td>
<td>View Confidence</td>
<td></td>
<td>Insert Entity</td>
</tr>
<tr>
<td>D</td>
<td>Deselect</td>
<td></td>
<td></td>
<td>Show Desktop</td>
<td>Show Desktop</td>
</tr>
<tr>
<td>E</td>
<td>QuickCapture</td>
<td>New Entity</td>
<td>Add Entity as Successor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>0% confidence (False)</td>
<td>Find</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>G</td>
<td>New Group</td>
<td></td>
<td>View Edge Weights</td>
<td></td>
<td></td>
</tr>
<tr>
<td>H</td>
<td>Hide App&lt;sup&gt;M&lt;/sup&gt;</td>
<td>Hoist Selected Group</td>
<td></td>
<td>Hide Other Apps&lt;sup&gt;M&lt;/sup&gt;</td>
<td></td>
</tr>
<tr>
<td>I</td>
<td>Italic</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>L</td>
<td>Hide Sidebar</td>
<td>Lock Desktop&lt;sup&gt;L&lt;/sup&gt;</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>M</td>
<td>View Project Management</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>N</td>
<td>New Document</td>
<td>View Annotation Numbers</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>O</td>
<td>Open</td>
<td></td>
<td></td>
<td>New Domain</td>
<td></td>
</tr>
<tr>
<td>P</td>
<td>Print</td>
<td>Export as PDF</td>
<td>Select Predecessors</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Q</td>
<td>Quit&lt;sup&gt;M&lt;/sup&gt;</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Reset Confidence</td>
<td>Reveal Selection</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>Save</td>
<td>Save As</td>
<td>Select Successors</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T</td>
<td>100% confidence (True)</td>
<td>Show Fonts</td>
<td>Toggle Focus</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Key</td>
<td>Normal</td>
<td>Ctrl&lt;sub&gt;WL&lt;/sub&gt;/Cmd&lt;sup&gt;H&lt;/sup&gt;</td>
<td>Alt&lt;sub&gt;WL&lt;/sub&gt;/Opt&lt;sup&gt;H&lt;/sup&gt;</td>
<td>Ctrl&lt;sub&gt;WL&lt;/sub&gt;/Cmd&lt;sup&gt;H&lt;/sup&gt; + Shift</td>
<td>Ctrl&lt;sub&gt;WL&lt;/sub&gt;/Cmd&lt;sup&gt;H&lt;/sup&gt; + Alt&lt;sub&gt;WL&lt;/sub&gt;/Opt&lt;sup&gt;H&lt;/sup&gt;</td>
</tr>
<tr>
<td>-----</td>
<td>--------</td>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>---------------------------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>U</td>
<td>50% confidence (Unknown)</td>
<td>Underline</td>
<td>Unhoist to Top</td>
<td>Unhoist One Level</td>
<td></td>
</tr>
<tr>
<td>V</td>
<td>Paste</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>W</td>
<td>Close Tab</td>
<td></td>
<td>3.0 Close Window</td>
<td>Swap Elements</td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>Cut</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Y</td>
<td>Redo</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z</td>
<td>Undo</td>
<td>Redo</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete/Backspace</td>
<td>Delete/Delete group, promote contents</td>
<td>Delete/Delete group and contents</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>,</td>
<td>Preferences</td>
<td></td>
<td></td>
<td>Zoom to Fit</td>
<td></td>
</tr>
<tr>
<td>.</td>
<td></td>
<td></td>
<td>Full Size</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[</td>
<td>Collapse</td>
<td></td>
<td></td>
<td>Deep collapse</td>
<td></td>
</tr>
<tr>
<td>]</td>
<td>Expand</td>
<td></td>
<td></td>
<td>Deep expand</td>
<td></td>
</tr>
<tr>
<td>&lt;</td>
<td>Zoom In</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>&gt;</td>
<td>Zoom Out</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>0% confidence/weight</td>
<td>Document Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>10% confidence/weight</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>20% confidence/weight</td>
<td>Domain Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>30% confidence/weight</td>
<td>Navigation Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>40% confidence/weight</td>
<td>Layout Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----</td>
<td>--------</td>
<td>-------------</td>
<td>--------------</td>
<td>-----------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>5</td>
<td>50% confidence/weight</td>
<td>Operators Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>60% confidence/weight</td>
<td>Element Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>70% confidence/weight</td>
<td>Text Inspector</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>80% confidence/weight</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>90% confidence/weight</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tab</td>
<td>Reduce selection/Edit</td>
<td>Switch applications\textsuperscript{L}, Switch windows\textsuperscript{W}</td>
<td></td>
<td>Switch panels\textsuperscript{L}</td>
<td></td>
</tr>
<tr>
<td>Escape</td>
<td>Clear copy-set</td>
<td>Processes\textsuperscript{L}</td>
<td></td>
<td>Kill window\textsuperscript{L}</td>
<td></td>
</tr>
<tr>
<td>+</td>
<td>100% weight</td>
<td>Change resolution\textsuperscript{L}</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-</td>
<td>-100% weight</td>
<td>Change resolution\textsuperscript{L}</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
<td>Select Head Entity</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>\</td>
<td></td>
<td>Select Tail Entity</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Arrows</td>
<td>Move selection</td>
<td>Scroll Canvas\textsuperscript{W}</td>
<td>Scroll Canvas\textsuperscript{M}</td>
<td>Switch Workspace\textsuperscript{L}</td>
<td></td>
</tr>
<tr>
<td>LMB</td>
<td>Select/Move edge</td>
<td>Select or multiselect\textsuperscript{W} (Shift on Mac)</td>
<td>Marquee Selection</td>
<td>Move window\textsuperscript{L}</td>
<td></td>
</tr>
<tr>
<td>F4</td>
<td></td>
<td></td>
<td></td>
<td>Close app\textsuperscript{W}</td>
<td></td>
</tr>
<tr>
<td>F(N)</td>
<td></td>
<td></td>
<td></td>
<td>Change Terminal\textsuperscript{L}</td>
<td></td>
</tr>
</tbody>
</table>
Preferences

The Preferences dialog is displayed using the Edit ➤ Preferences... (Win) or Flying Logic ➤ Preferences (Mac) command.

General Options

Auto-Backup on Save

The Auto-Backup on Save checkbox determines whether a backup file of the last saved version is created each time an existing document is re-saved.

Opening Files

Flying Logic can open documents in their own window, as a tab in the current active window, or ask how to open each document.

Check for Updates Automatically

When selected, Flying Logic will periodically use your Internet connection to check whether an updated version is available for download.

Undo Levels

Flying Logic keeps track of the number of undo levels entered into this box. The default is 100.

Recent Documents

Flying Logic keeps track of this number of recently opened documents in File ➤ Open Recent. The default is 20.

Recent Scripts

Flying Logic keeps track of this number of recently run scripts (Max Scripts), importer scripts (Max Importers), and exporter scripts (Max Exporters). The default is 4.

Auto-Edit New Entity Titles

By default Flying Logic requires you to press Tab after creating an entity in order to edit its title. But since editing an entity’s title immediately after creating it is such a common operation, you can make it the default behavior by turning on this option.
Disable Control-Alt Menu Shortcuts

(Windows Only) Some international keyboard layouts require the Control-Alt modifier combination for typing. In this case, setting this preference causes Flying Logic to not use this modifier combination for its menu shortcuts.

**Note:** Flying Logic must be restarted for this preference to take effect.

Display Options

Each time the diagram changes, an animated transition is shown between the old state and new state. Several aspects of this transition are controllable via preferences.

**Fixed-Speed vs. Adaptive Speed**

If the Adaptive Animation box is unchecked, each transition will take a fixed amount of time controlled by the Animation Speed (Seconds) slider. If the Adaptive Animation box is checked, each transition will take an amount of time determined from the “visual complexity” of the animation. With adaptive animation, simple changes to the diagram result in quick animations, while complex animations with many objects moving result in slower animations that allow the eye to better track the changes. With adaptive animation, the Speed slider can still be used to control whether the animations happen faster or slower.

**Turning Off the Animation**

If the Adaptive Animation box is unchecked and animation speed is set to zero seconds, the animation does not take place, and layout changes to the diagram appear instantly.

**Animation Style**

The animation style radio buttons control how Flying Logic chooses which frames of the animation to generate. If Fixed Frame Rate is selected, then Flying Logic will choose a number of frames over which to perform the animation based on the animation speed (at a nominal 30 frames-per-second) and will draw every one of those frames. This option may look better on slower hardware. The preferred, default style is Fixed Time, where Flying Logic dynamically chooses which frames to
draw based on the amount of time the last frame took to draw. This results in animations running at what often feels like a steadier pace, and is particularly suitable to faster hardware. Try both options and keep the one that feels best to you.

**Edge Colors**

The color of edges in your diagrams depends on this setting. The default is **Red..Gray..Black**, which means that edges with negative weights are drawn in red, edges with neutral settings are drawn in gray, and edges with positive weights are drawn in black. The other options are **Red..Yellow..Black** and **Red..Yellow..Green**.

**Spinner Display**

The Spinner Display preference determines what symbols are drawn inside of spinners.

<table>
<thead>
<tr>
<th>None</th>
<th>Symbol</th>
<th>Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Confidence Spinner</strong></td>
<td><em>nothing</em></td>
<td>0%: <em>F</em> 100%: <em>T</em> other values: <em>nothing</em></td>
</tr>
<tr>
<td><strong>Edge Weight Spinner</strong></td>
<td><em>nothing</em></td>
<td>-100%..-1%: <em>–</em> 0%: <em>O</em> 1%..100%: <em>+</em></td>
</tr>
<tr>
<td><strong>% Complete Spinner</strong></td>
<td><em>nothing</em></td>
<td>0%..99%: <em>nothing</em> 100%: <em>C</em></td>
</tr>
</tbody>
</table>

**Default Orientation and Default Bias**

The Default Orientation and Default Bias settings control the orientation (flow direction) and bias of newly-created documents. Any document can have its orientation or bias changed using the Layout Inspector. For more information see “**Layout** on page 50.”
Project Options

These preferences apply only when Project Management is enabled.

Default Standard Calendar

3.0 This setting determines the number or work hours in a day for the Standard calendar of any newly-created document or documents that were created in Flying Logic 1 or 2.
Appendix A– Project Management

A Work in Progress

Flying Logic Pro 2.0 introduced experimental support for Project Management features, which have been expanded for Flying Logic Pro 3.0. Currently, we only support a subset of features necessary for Flying Logic to replace a fully-featured package such as Microsoft Project™ or OmniPlan™.

Features Currently Supported

- Project start date
- Rudimentary support for project calendar (weekdays)
- Weekday exceptions calendar
- Task effort (days only)
- Per-task start and finish dates, calculated or assigned
- Task percent complete
- Milestones
- Finish-to-start (F2S) task dependencies
- Rolling up start/finish date summaries to groups
- Export to Microsoft Project (can also be imported by OmniPlan)
- Scheduling granularities other than days (minutes, hours)
- Creating and assigning resources to tasks
- Gantt charts
- Resource calendars

Features Not Yet Supported

- Start-to-start (S2S), start-to-finish (S2F), and finish-to-finsh (F2F) task dependencies
- Lead and lag time on task dependencies
- Work Breakdown Structure (WBS) coding
- Resource leveling
- Full support for project calendar
- Costing and budgeting

Enabling Project Management

Using Flying Logic for project management is as simple as creating a new document and then clicking the Project Management icon in the
Toolbar, or selecting **View ➤ Project Management**. Turning on Project Management changes the appearance of entities in the canvas and several inspectors, which are described in detail in the following sections:

- Entities gain labels for Start Date, Finish Date, Effort, and spinners for Percentage Complete.
- The Document Inspector gains a new Project Management tab.
- The Entity tab of the Element inspector contains fields for Start Date, Finish Date, Effort, Percentage Complete, Resources, and Resource Assignment.

- When creating a custom entity class, there is an option to have entities of the class be a milestone by default; i.e., a task with zero effort.

**Project Settings**

The Project Management tab of the Document Inspector is where you set up your general project attributes.
The **Start Date** and **Finish Date** fields specify the start date (or finish date) for all non-dependent tasks with no specifically assigned start (or finish) date. The arrow button between the fields determines whether the project is scheduled from the start date or the finish date. When scheduling from the start date the Finish Date field is not editable, and when scheduling from the finish date the Start Date field is not editable.

**3.0** If a project does not start at the beginning of the Start Date or ends before the end of the Finish Date, a “clock” indicator will appear to the right of the date. If the date is currently editable, then the indicator will also act as a button. When pressed, the project will be reset to either start at the beginning of the day or finish at the end the day.

**3.0** Each document has a standard work calendar. The settings for this calendar can be edited via the following controls.
The **Workdays** check boxes determine which weekdays will be considered work days for the purposes of date calculations.

The **Hours** control can be used to set the number of hours in a workday. This affects the meaning a day has when it appears in the effort control in the Element inspector’s Entity tab. Any hour amount greater than or equal to one day will be converted to an amount that includes a day amount; e.g., if the Standard calendar has an 8 hour workday, then an effort of 20 hours is displayed as “2 days, 4 hours.”

The **Resources...** button opens the Resources dialog that allows the creation of named resources that can be assigned to perform tasks associated with entities. The dialog can also be used to edit and remove resources.

Resource names must be unique within their document, although abbreviations do not have to be unique. Newly added resources start with a utilization of 100% and use the Standard calendar, but either of these can be changed.

**Utilization** indicates a percentage of the hours per workday assigned to
the resource based on the calendar. This is an alternate way to indicate a resource works less hours per day instead of creating a new calendar.

The **Calendars...** button opens the Calendars dialog that allows for the editing, adding and removing alternate calendars. These alternate calendars can then be assigned to resources.

To edit a calendar select it from the combo box. The Standard calendar is also included in this list for convenience.

When creating a calendar you will be asked to provide a name and indicate which existing calendar the new calendar is based upon. Each calendar must have a unique name. In addition to any existing calendar, the new calendar can also be based on the Document Default calendar as set in Project preferences.

The **Exceptions...** button opens the Weekday Exceptions Calendar, where you can specify exceptions to the regular work week (holidays.)

When you turn Project Management on for a document for the first time, additional information to support project management is added to it. The **Remove All Project Management Info** button is used to remove all project management information from the document and turns Proj-
ect Management off. You will only rarely need to use this feature. If you simply want to hide project management information without removing it from the document, just select View ➤ Project Management again.

**The Project Management Domain**

Flying Logic does not have a built-in domain for Project Management, but an custom domain is available as an example. Select the File ➤ Open Examples... menu item, select the Domains tab in the Open Example dialog, and double-click the Project Management folder to find Project Management.xlogic-d. Double-click on this domain to add it to the current document or create a new document that includes this domain. This domain has five entity classes:

- Milestone (a class with a default effort of zero days)
- Fixed-Effort Task (default resource assignment of Fixed Effort and effort of one day)
- Fixed-Duration Task (default resource assignment of Fixed Duration and effort of one day)
- Fixed-Both Task (default resource assignment of Fixed Effort and Duration and effort of one day)
- Task (same as Fixed-Effort Task, included for compatibility with Flying Logic 2)

If you are only going to used the Project Management domain in a document, consider hiding the built-in domains (see “Hiding Domains” on page 73).

**Entities as Tasks**

Flying Logic entities are used to represent tasks and milestones. Tasks with non-zero effort show Start Dates, Finish Dates, and Percentage Complete spinners, while tasks with zero effort only display a Finish Date. Start or Finish dates which have been specifically assigned in the Entity tab of the Element Inspector are displayed in bold.
Tip: Merely setting a task’s effort to zero will not change it to the Milestone class, nor will setting a task’s effort non-zero change it to the Task class: you must assign classes yourself based on your intent for the entity.

**Effort vs. Duration**

The *duration* of a task, that is, how much calendar time it will take to complete, is determined by the amount of effort the task requires, the resources performing the task, and what calendar the resource will be working on. Flying Logic does not yet support resources or fully-featured calendars, so the duration of tasks is determined by the task’s effort (in days) and which weekdays are marked as workdays in the Project Management tab of the Document Inspector. For example, if you assign a task an effort of 2 days, the start date of the task is a Friday, and only Monday through Friday are counted as work days, then the duration of the task is 4 days, with that Friday and the following Monday being the 2 days of effort required, and the intervening Saturday and Sunday counting towards the task’s duration, but not its effort.

Each task’s effort is set in the Entity tab of the Element Inspector. A task’s duration is always the difference between its Start Date and Finish Date.

**Calculated Dates vs. Assigned Dates**

By default a task’s Start Date is based on the latest Finish Date of all its predecessor tasks (or the project Start Date if it has no predecessors),
and its Finish Date is based on the task’s effort spread over the necessary number of calendar days, skipping non-work days.

There are times when you need to constrain a task to start or finish on a given date. You can do this by entering a specific date in the Start Date, or Finish Date fields of the Element Inspector’s Entity tab. Constraining both dates results in the same amount of effort being spread out over (or compressed into) the assigned dates.

![Element - Entity](image)

**Assigned Start Date**

**Calculated Finish Date**

**Entering Effort Values**

3.0 The effort value can be changed by entering a new amount given in days, hours, and minutes optionally separated by commas. You can abbreviate “day” or days” as “d”, “hour” or “hours” as “h”, and “minute” or “minutes” as “m”. Also, any number with no time unit indicated will be assumed to be the next smallest time unit. Here are some examples:

<table>
<thead>
<tr>
<th>Effort</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 day</td>
</tr>
<tr>
<td>2 days</td>
</tr>
<tr>
<td>2 day</td>
</tr>
<tr>
<td>2d</td>
</tr>
<tr>
<td>1 day, 4 hours</td>
</tr>
<tr>
<td>1 day, 4h</td>
</tr>
<tr>
<td>1 d 4 h</td>
</tr>
<tr>
<td>1.5d</td>
</tr>
<tr>
<td>12h</td>
</tr>
</tbody>
</table>

A “day” is equal to the number of hours in the Standard calendar. In the example effort amounts above, the two in the fourth row are identical to those in the third row, if the standard work hours per day is 8.

The Resources drop-down menu can change which resources are assigned to a task. To clear a task of any assigned resources, choose the Default item.

The Assignment list can be used to change how multiple resources are applied to a task. The **Fixed Effort** setting divides the current effort
across all the resources, which reduces the duration of the task per newly assigned resource. The **Fixed Duration** setting indicates that each resource must expend the same amount of effort regardless of total resources, which increases the total effort for each newly assigned resource. Finally, in the **Fixed Effort and Duration** a.k.a. **Fixed Both** setting, each resource only uses part of their time on the task. All other things being equal, two resources will have 50% utilization, three resources will have 33.3% utilization, etc.

**Percentage Complete**

A task’s Percentage Complete can be adjusted from the Entity Inspector, or directly in the Canvas by manipulating the spinner.

**Tip:** Unlike Confidence spinners, which are calculated based on predecessor entities, Percentage Complete spinners are all independent. It is up to you to determine when each task or milestone is complete and mark it as such.

**Project Management Features of Chart View**

When Project Management is enabled, additional features appear in chart view.

<table>
<thead>
<tr>
<th>#</th>
<th>Title</th>
<th>Entity Class</th>
<th>Effort</th>
<th>Start</th>
<th>Finish</th>
<th>Resource</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>Task</td>
<td>1 day</td>
<td>7/22/15</td>
<td>7/22/15</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>B</td>
<td>Task</td>
<td>1 day</td>
<td>7/23/15</td>
<td>7/23/15</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>C</td>
<td>Task</td>
<td>1 day</td>
<td>7/24/15</td>
<td>7/24/15</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>D</td>
<td>Milestone</td>
<td>0 days</td>
<td>7/24/15</td>
<td>7/24/15</td>
<td></td>
</tr>
</tbody>
</table>

The width and positioning of elements are changed to match the calculated schedule for tasks as indicated by the dates and days of the week that appear in the column header.

Project management specific values now appear in each row. The width of the Resources column can be changed just like the Title and Class columns.

A green completeness bar appears along the middle of entity elements with non-zero effort and completeness.
**Edges as Dependencies**

Edges between entities represent dependencies between tasks, with a successor task calculated to start after the latest Finish Date of all its predecessor tasks. This is known as finish-to-start (F2S) dependency, and is the most commonly found in project management. Other sorts of dependencies such as start-to-start (S2S) are also used, as is the practice of assigning a positive “lag” time or negative “lead” time to dependencies, however Flying Logic does not currently support these concepts.

**Groups as Summaries**

When Project Management is turned on, groups display the earliest Start date and latest Finish Date of all their enclosed tasks and subgroups.

---

### Notes on MS Project Export and Import

When exporting a diagram to MS Project exchange format, Flying Logic performs the following conversions:

- Entities and junctors become tasks.
- Groups become summaries.
- Edges determine which tasks are considered predecessors of other
tasks. All other attributes of edges are not exported.

- Entity and group titles, plus junctor names, become task names.
- Annotations for entities, junctors and groups become task notes.
- Text 1 field of the task is set to the element type ("Entity", "Junctor" or "Group").
- Text 2 field of the task is set to entity class (entities only).
- Text 3 field of the task is set to the user-defined attributes of the element.
- Number 1 field of the task is set to the confidence (entities and junctors only).
- If project management is enabled, calendars and resources are exported.
- All tasks are marked as auto-scheduled. The exception is entities with a preferred start or finish date, which are marked as manually scheduled.
- Entities with a user-defined attribute named "MSProjectGroup" are not exported but are used to modify the export of their direct parent group. See below for details.

When importing a diagram from MS Project exchange format, Flying Logic performs the following conversions.

- Tasks become entities unless the Text 1 field of the task is "Junctor" or "Group".
- The entity class of entities is set to the Text 2 field of the task if the Text 1 field is "Entity".
- In the case where no explicit entity class is assigned as above, the entity classes from the Project Management domain are assigned to entities based on the task attributes, if that domain exists in the document.
- Summaries become groups and may cause the generation of special entities (see below).
- Task notes become annotations.
- The user-defined attributes of the element are set to the Text 3 field of the task.
- The confidence of an entity are set the Number 1 field of the task.
- Calendars and resources are imported.
- If a task is manually-scheduled, the resulting entity’s is given a preferred start date.

Because MS Project summaries can have predecessors, but Flying Logic groups do not, some special rules are applied to allow for performing a round-trip of documents.

If a summary has a predecessor, the corresponding group will have a child entity with the same title as the group with “* START” appended (or just “START” if the group has no title) and a user-defined attribute named “MSProjectGroup” with a value of start. This entity will have all the summary’s predecessors as predecessors. The entity itself is a milestone; i.e., have an effort of zero.

If a summary has a successor, the corresponding group will have a child entity with the same title as the group with “* FINISH” appended (or just “FINISH” if the group has no title) and a user-defined attribute named “MSProjectGroup” with a value of finish. This entity will have all the summary’s successors as successors. The entity itself is a milestone.

Finally, if a summary is manually-scheduled, it will have a child entity with the same title as the group with “* SUMMARY” appended (or just “SUMMARY” if the group has no title) and a user-defined attribute named “MSProjectGroup” with a value of summary. This entity will
have the same effort and preferred start date as the summary.

During export, any entity in a group with a user-defined attribute named “MSProjectGroup” will be used to modify the exported summary so it has the proper predecessors, successors and scheduling. These special entities are not exported.

You can create entities with the user-defined attribute “MSProjectGroup” directly and have them apply similar modifications during export!